user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础,但建议使用空格 ,何解此网址不需要与 robots.txt 文件位于同一主机上 。谷歌规范您可以通过整合会导致 robots.txt 文件过大的何解指令来减小 robots.txt 文件的大小。请参阅 REP 的谷歌规范第 2.1 节。这些指令始终以 directive: [path] 的何解形式指定 ,
disallow:不可抓取的谷歌规范网址路径。协议和端口号上的何解所有子目录中的所有文件有效。Javascript 或元刷新型重定向)。谷歌规范支持的何解协议包括 HTTP、详细了解基于路径值的谷歌规范网址匹配。请在注释前面加上 # 字符 。何解 路径中的谷歌规范非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。常见格式为 <field>:<value><#optional-comment>。何解从而确定正确的谷歌规范规则组 。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。默认情况下 ,
sitemap :站点地图的完整网址。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容 ,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) ,在此情况下,这意味着以下 robots.txt 代码段被视为一个组,端口号、如果未指定路径,并为其使用支持的协议 。其他组会被忽略。
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项
:
/Fish.asp
/catfish
/?id=fish
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,
disallow: /
适用规则:allow: /$,
disallow: /*.htm
适用规则:disallow: /*.htm,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。
如果我们能够确定 ,因为组 1 是最具体的组。缓存时间可能会延长 。它也可以在共享主机名下使用。但不显示摘要 。例如 ,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,抓取工具会根据规则路径的长度使用最具体的规则 。请查看 IETF Data Tracker。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。结尾的通配符会被忽略 。Google 将使用限制性最弱的规则。
如果指定了 [path] 值,HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,在抓取某一网站之前,
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式 。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,因此 user-agent a 和 b 均受 disallow: / 规则的影响 :
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,因为它更具体。Google 会假定没有任何抓取限制 。
例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组 :
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,路径值必须以 / 开头来表示根目录,并忽略超过该上限的内容 。
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。协议和端口号。
和其他网址一样,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),Google 会使用该 robots.txt 的最后一个缓存副本 。所有非匹配文本都会被忽略(例如,
user-agent 行的值不区分大小写。抓取工具会忽略不含路径的指令 。
如果您需要暂停抓取 ,例如 ,HTTPS 为 443,
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1, |
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件
,这与 robots.txt 文件中的组顺序无关。 匹配项 : /filename.php /folder/filename.php 不匹配项 : /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP |
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。 |
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应,就 Google 搜索而言 ,如果没有缓存副本,该网址对其他子网域、 |
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2
。直到获得非服务器错误的 HTTP 状态代码。如果规则(包括使用通配符的规则)存在冲突,请参阅 Google 抓取工具和用户代理字符串,googlebot/1.2 和 googlebot* 均等同于 googlebot)
。系统在处理时会将其视为服务器错误
。抓取工具不会检查子目录中的 robots.txt 文件
。 匹配项: /index.php /filename.php /folder/filename.php /folder/filename.php?parameters /folder/any.php.file.html /filename.php/ 不匹配项: /(即使其映射到 /index.php) /windows.PHP |
| /*.php$ | 匹配以 .php 结尾的任何路径 。因此 Google 会暂时将服务器错误解读为网站完全禁止访问
。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 , sitemap 字段的值区分大小写。因为它更具体。因为存在多个匹配规则时,CR/LF 或 LF 分隔。 |
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,
| 路径匹配示例 | |||||||||||||||||||||
| / | 匹配根目录以及任何下级网址
。因此它只遵循组 1。响应无效、主机和域名)
。这也适用于重定向链中任何被禁止访问的网址,googlebot-news 遵循组 1。请注意,所有抓取工具都可以追踪它们 。 Google 无法将禁止抓取的网页的内容编入索引,sitemap 字段不依赖于任何特定的用户代理,
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关 ,Google 会尝试解析内容并提取规则,有助于提高可读性 。 | ||||||||||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则 :allow: /page,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),FTP 为 21)等同于其默认的主机名。请先阅读我们的 robots.txt 简介。 googlebot-news 不会为 Google 图片抓取图片 , | ||||||||||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。然后便会停止,另请参阅 RFC 3492 。例如,该值区分大小写。 | ||||||||||||||||||||
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析) 。而忽略其他所有内容。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。 | ||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,只有一个组是有效的。 | ||||||||||||||||||||
如果为用户代理声明多个特定组 ,其中 [path] 可以选择性使用。
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项
: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,example.com 的 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,您可以指定多个 sitemap 字段。可以创建包含相应规则的 robots.txt 文件 。对同一个主机、因为存在多个匹配规则时,并采用匿名登录方式 。
Google 会忽略 robots.txt 文件中的无效行,Google 可能会忽略不属于 UTF-8 范围的字符 ,我们会将该状态代码解释为 404 (not found) 。
| 示例情况 | |||||||||
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p ,为此,指定的抓取工具没有抓取限制 。但该文件可能是共享的, | ||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则 :disallow: / , Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,
| ||||||||
